タグ別アーカイブ: XAMPP

Mac版XAMPPとMediaWikiの組み合わせで動かしてみようとしている人は注意

最近MediaWikiをインストールして動かしてみようと思ったのですが、
XAMPPのドキュメントルートにMediaWikiのソースを配置してブラウザ上のインストーラ画面から設定している最中に、「PHP5.3.1では動かせない」旨のエラーメッセージが出力されて、それ以上先に進めなくなりました。

PHP5.3.1にはバグが存在していて、MediaWikiではわざと動作させない仕組みになっているみたいです。
ネットで少し検索してみたところ、MediaWikiの英語版のサイトに

Please note that MediaWiki does not work with the current version XAMPP 1.7.3, as it uses PHP 5.3.1, which has a bug, making it incompatible with MediaWiki. Either use XAMPP 1.7.2, or use the XAMPP 1.7.4 beta.

との注意書きが赤字で書いてありました。

XAMPPは簡単にPHP+MySQLの環境が作れるので、使っている方も多いと思います。
Windows版のXAMPPはすでにバージョン1.7.4が公開されているので問題はなさそうですが、Mac版のXAMPPは2011/2/24現在の最新バージョンがまだ1.7.3で、普通にXAMPPのサイトからダウンロードしてインストールするとこのバージョンになってしまいます。

sourceforge.netから1.7.4 betaをダウンロードしてインストールし直すとすんなり動くようになりました。